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Board Shape & Sheet Basics 

Summary  
Tutorial  
TU0110 (v1.0) December 9, 2003   

This tutorial covers board shapes, sheets, templates and 
keepouts used in DXP’s PCB Editor. 

 

  

The board shape defines the boundary, or extents, of the board in the PCB Editor. The board shape 
may also be referred to as a board outline and is essentially a closed polygon. It initially displays as a 
black area with the visible grid on by default when you create a new PCB document. It is used by DXP 
to determine the extents of the power planes for 
plane edge pull back, used when splitting power 
planes and for calculating the board edge when 
outputting design data to other tools, such as the 
3D viewer.   

When a new board file is created by selecting 
File » New » PCB from the menus, a default 
board shape is created, sized 6,000 x 4,000 mils. 
The board shape can be resized, or redefined, 
using the commands in the Design » Board 
Shape sub-menu. PCB documents created using 
the PCB templates or the PCB Board Wizard 
have the board shape already correctly sized. 

Modifying a board shape 
You can change a board shape by redefining 
(redrawing) it or by moving the vertices. You can 
move the board shape around the sheet as well, with or without any placed objects. 
You can change the color of the board shape by selecting Design » Board Layers & Colors (shortcut 
key L) and selecting a new color for the Board Area in the System Colors section of the Board Layers 
& Colors dialog. 

Redefining a board shape 
You can redefine the board shape if it does not already exist or you want to draw it again from scratch. 
If you need to change the entire board shape, complete the following steps. 
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1. Select Design » Board Shape » Redefine Board Shape. The cursor will change to a large cross, 
the background will change to black and the original board shape will be displayed in green. 

2. Click (or press ENTER) to create the corners of the new board shape. Press the SPACEBAR to 
change the corner style while you are defining the board shape. The Status bar at the bottom of the 
design window helps to locate the co-ordinates of the corners.  

 

3. When you have defined the board shape, right-click or press ESC to finish. There is no need to fully 
close the polygon as DXP will automatically complete the shape by joining the first point to the last 
point placed.  

The visible grid will be drawn to fill the area defined by the new board outline. 

Defining the board shape from selected objects 
You can define an enclosed boundary, using lines and arcs, on a mechanical layer (or any layer) and 
use these objects to define the board shape. 

To define a board shape from selected objects: 

1. Create an enclosed boundary on a mechanical layer that will define the board shape you require. 
Use the placement commands such as Place » Line or Place » Arc to create your new board 
shape. 

2. Select the new board shape boundary only.  
3. Select Design » Board Shape » Define from Selected Objects and the board shape will be 

redisplayed to fit the selected boundary objects.  

Moving board vertices 
When modifying a board shape, e.g. resizing it, moving the board vertices will save you from having to 
redefine the entire board shape.  
1. Select Design » Board Shape » Move Board Vertices. The board outline displays with editing 

handles and the cursor changes to a large cross, ready to select and move vertices.  
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2. Click on the vertex that you want to move and drag it to its new location.  

3. You can create new vertices by clicking on the small crosses that appear midway along the line 
segments and dragging the new vertex into position.   

4. Right-click or press ESC to finish your board shape. 

Moving the board shape 
Using the Move Board Shape command to reposition the board shape will move the board outline only. 
Any components and connections already placed will not be affected.  

If you need to reposition the board shape in relation to the design sheet, make sure the sheet is visible 
by enabling the Display Sheet option in the Board Options dialog (Design » Board Options). See 
Using PCB sheets in this tutorial for more information about using sheets in DXP. 

To move a board shape only: 
1. Select Design » Board Shape » Move Board Shape and the outline will appear floating on the 

cursor.  

2. Drag the board shape to its new location and click to place. 

To move a board shape along with any components and connections already placed: 
1. Select all (Ctrl+A) or select the objects you need to move, including the board shape.  

2. Click directly on a selected object and the cursor changes to a large arrow. Drag the selection 
bounding box to the new location on the sheet.  
Alternatively, select the objects required and select Edit » Move » Move Selection. Click within the 
selection to define a reference point, move the selection and click to place. 

Using PCB sheets 
Sheets in the PCB Editor are a special drawing feature, controlled using the options in the Board 
Options dialog. When you create a new PCB file, a default sheet is automatically created with the 
default size of 10000 x 8000 mil. It is not shown initially but, when displayed, it appears as the white 
shape behind the board outline. 
Most of the PCB example files supplied with DXP (C:\Program Files\Altium2004\Examples) 
display the board on a white sheet which includes a border, grid reference and title block that have 
been drawn on one of the mechanical layers, Mechanical16.  

By placing objects on mechanical layers and then linking those layers to the sheet, you can create your 
own drawing templates which can be displayed or hidden. Sheets that include a border, grid reference 
and title block can be added to PCB files by copying from the existing PCB templates (C:\Program 
Files\Altium2004\Templates). 
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The sheet size and location of the sheet can be defined manually, or the sheet can be resized 
automatically to fit the objects on the linked mechanical layer when you select View » Fit Sheet. 

Displaying the sheet 
To make the sheet is visible in the PCB Editor: 
1. Select Design » Board Options and select the Display Sheet option in the Sheet Position section 

of the Board Options dialog. Click OK. 

The sheet can be hidden at any time by disabling the Display Sheet option. All linked mechanical 
layers will also be hidden. 
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2. Select View » Fit Sheet to display the sheet. Alternatively, use the shortcut keys, V, H (View Sheet) 
or Z, S (Zoom Sheet). A white space appears around the board shape with the default size of 
10000 x 8000 mil.  

 

3. You can change the color of the sheet by selecting Design » Board Layers & Colors (shortcut key 
L) and selecting a new color for the Sheet Area and Sheet Line in the System Colors section of the 
Board Layers and Colors dialog. 
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Adding a new sheet from a PCB template 
You can add a new sheet, including the sheet border, reference grid and title block, at any time by 
copying the objects from the supplied DXP PCB template documents and pasting them into your PCB 
design document. DXP includes a set of pre-defined PCB templates located at C:\Program 
Files\Altium2004\Templates. Use the sheet size templates only, i.e. A.pcbdoc through to 
A0.pcbdoc. 

1. Open the PCB document that you want to add the new sheet size to. Make sure that the existing 
default sheet is displayed to help you place the new sheet by pressing V, H (view sheet) or Z, S 
(zoom sheet). 

2. Open an existing PCB sheet template that will fit all the objects on your PCB, e.g. A2.pcbdoc. To 
do this, click on PCB Templates in the New from Template section of the Files panel. If this 
option is not visible, click on the up arrows to the right of each section in the Files panel to contract 
the other options. The Choose existing Document dialog displays. 

 

Navigate to the PCB templates folder (C:\Program Files\Altium2004\Templates) and 
select A2.pcbdoc (for example) and click Open. The template is opened as a new PCB design 
document in the design window, named PCB1.PcbDoc. 

3. Select all the contents of the template file (Ctrl+A) and copy (Ctrl+C) the contents to the clipboard. 
Click once to set a copy reference point. Close Pcb1.pcbdoc without saving. 

4. Switch to your PCB document by clicking on its tab at the top of the design window. Paste the new 
sheet into the existing PCB using Ctrl+V. The contents of the template are pasted onto 
Mechanical16 layer. 

5. Now we need to show the Mechanical16 layer and link it to the sheet. Select Design » Board 
Layers & Colors to display the Board Layers and Colors dialog. Click on Show, Enable and 
Linked to Sheet.  
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6. Also turn on Single Layer Mode to always show the sheet regardless of the status of Single Layer 
Mode as enabled in the Display tab of the Preferences dialog (Tools » Preferences). Click OK to 
close the dialog. 

 

7. Finally we can size the sheet to include the sheet border. Press V, H (to view sheet) or Z, S (to 
zoom sheet). The sheet fits to the extents of the objects on the layer linked to the sheet, i.e. it fits to 
include the sheet border defined on the Mechanical16 layer. 

8. You can now modify the title block, for example, by switching to Mechanical16 layer and adding or 
deleting objects. The sheet will resize to include all objects when you press V, H (view sheet) or Z, 
S (zoom sheet) again. 

Keepouts 
The keepout is a separate entity to the board shape. A keepout shape, usually made up of placed 
keepout tracks, is required on the PCB Keepout layer if you intend to run the autorouter or autoplace 
components. A keepout track is simply a track placed on the Keepout layer with the Keepout attribute 
enabled.  

A keepout is automatically generated if you create the PCB by using the PCB Board Wizard where you 
can nominate the distance of the keepout from the edge of the board shape. The dimensions 
generated by the PCB Board Wizard measure the keepout not the board shape size. The diagram 
below shows an example of a keepout outline generated on the Keepout layer by the PCB Board 
Wizard, indented 100mil from the edge of the board shape of 2000 x 2000 mil. 
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Track placement modes 
are available when 
placing a keepout. 
Press SHIFT+ 
SPACEBAR to cycle 
through the modes. 
Press SPACEBAR to 
toggle between Start 
and End modes. 
Use BACKSPACE to 
remove the last placed 
track segment. 
Press TAB to display the 
Line Constraints dialog 
and change properties. 

 
A board keepout is also automatically included when using a PCB manufacturers’ template to create a 
new PCB, e.g. AT or Eurocard. The sheet size templates, e.g. A2.pcbdoc, do not include keepouts.  

Creating a keepout 
Since a keepout is required if you wish to autoplace components or autoroute the 
board, you will need to add the keepout yourself if you create a new PCB in the 
following ways: 
• selecting File » New » PCB from the menus , or clicking on PCB File in the 

New section of the Files panel,  

• using the PCB sheet size templates, e.g. A2.pcbdoc, by choosing PCB 
Templates from the New from Template section of the Files panel. 

Only a default board shape is created by these commands, so the keepout has to 
be added once the board shape has been defined. 

To create a keepout by placing keepout tracks: 
1. Click on the Keep-Out layer tab so you will be placing the keepout tracks on 

this layer only.  
2. Select Place » Keepout » Track. Click to define the vertex points of the 

keepout and create a closed polygon. 
3. When you have finished placing the keepout tracks, right-click or press ESC to exit track placement 

mode. 

Now you have created your board shape, sheet and keepout, set the grids, layers and design rules and 
you are ready to start designing your board. 



Board Shape & Sheet Basics 
 

TU0110 (v1.0) December 9, 2003 9 
 

Revision History 
 

Date Version No. Revision 

9-Dec-2003 1.0 New product release 

Software, documentation and related materials:  

Copyright © 2003 Altium Limited. 

All rights reserved. Unauthorized duplication, in whole or part, of this document by any means, mechanical or 
electronic, including translation into another language, except for brief excerpts in published reviews, is prohibited 
without the express written permission of Altium Limited. Unauthorized duplication of this work may also be 
prohibited by local statute. Violators may be subject to both criminal and civil penalties, including fines and/or 
imprisonment. Altium,  DXP, Design Explorer, nVisage, Nexar, Protel, P-CAD, Tasking, CAMtastic, Situs and 
Topological Autorouting and their respective logos are trademarks or registered trademarks of Altium Limited. All 
other registered or unregistered trademarks referenced herein are the property of their respective owners and no 
trademark rights to the same are claimed. 

 


	Board Shape & Sheet Basics
	Modifying a board shape
	Redefining a board shape
	Defining the board shape from selected objects
	Moving board vertices
	Moving the board shape

	Using PCB sheets
	Displaying the sheet
	Adding a new sheet from a PCB template

	Keepouts
	Creating a keepout

	Revision History


